import re
regex = re.compile(r"\b\d{8,12}\b", flags=re.MULTILINE)
test_str = ("e5655558888\n"
"r666666\n"
"t 5987442510\n"
"j69698888885\n"
"U 568457562388 11255525h555h4 4444444444444444 5655555/85 55555-555-23-23 55 This next section I do NOT want to be captured 636363666-66-12345678\n"
"I56588895620\n"
"56854444002 this number can be anywhere in the sentence ike this: 123456789 Or it could just be like this 98765432 these are good\n"
"but it should NOT find this 050860404-01e0-4a5a-b8db-a97f26a668ac\n"
"p 63666900000\n"
"bank account 12356895555\n"
"123456780000\n"
"2222\n"
"05086040\n"
"Not sure what the plan might be thought for when i have a sentence with account information for my checking account written in a document like this, here is the savings account number 1234567890. thank you. overdraft 9876543210")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")