$re = '/<script>[a-zA-Z0-9 \. \n \t\r \* \\\\ \*]*.<\/script>$/';
$str = 'vijay sharma<script>test sd234 $#
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);