re = /<script>[a-zA-Z0-9 \. \n \t\r \* \\ \*]*.<\/script>$/
str = 'vijay sharma<script>test sd234 $#
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end