#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=")\d+\S+(?=")"
Local $sString = " {" & @CRLF & _
" "CODE": "0021"," & @CRLF & _
" "TITLE": "Error: Customer Number Invalid"," & @CRLF & _
"}," & @CRLF & _
"{" & @CRLF & _
""CODE": "0A51"," & @CRLF & _
" "TITLE": "Error: Currency Invalid"," & @CRLF & _
"}," & @CRLF & _
"{" & @CRLF & _
""CODE": "043C"," & @CRLF & _
" "TITLE": "Error: Payment is Unbalanced"," & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")