re = /(?<=")\d+\S+(?=")/m
str = ' {
"CODE": "0021",
"TITLE": "Error: Customer Number Invalid",
},
{
"CODE": "0A51",
"TITLE": "Error: Currency Invalid",
},
{
"CODE": "043C",
"TITLE": "Error: Payment is Unbalanced",
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end