using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<="")\d+\S+(?="")";
string input = @" {
""CODE"": ""0021"",
""TITLE"": ""Error: Customer Number Invalid"",
},
{
""CODE"": ""0A51"",
""TITLE"": ""Error: Currency Invalid"",
},
{
""CODE"": ""043C"",
""TITLE"": ""Error: Payment is Unbalanced"",
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}