using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"example\.com\/account\/(|.*#home\.html|(\?(?!.*#.*).*))$";
string input = @"example.com/account/
example.com/account/?brand=mine
example.com/account/#home.html
example.com/account/?brand=mine#home.html
example.com/account/#other.html
example.com/account/?brand=mine#other.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}