import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "example\\.com\\/account\\/(|.*#home\\.html|(\\?(?!.*#.*).*))$";
final String string = "example.com/account/\n"
+ "example.com/account/?brand=mine\n"
+ "example.com/account/#home.html\n"
+ "example.com/account/?brand=mine#home.html\n"
+ "example.com/account/#other.html\n"
+ "example.com/account/?brand=mine#other.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}