re = /example\.com\/account\/(|.*#home\.html|(\?(?!.*#.*).*))$/m
str = 'example.com/account/
example.com/account/?brand=mine
example.com/account/#home.html
example.com/account/?brand=mine#home.html
example.com/account/#other.html
example.com/account/?brand=mine#other.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end