// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\|[pP]ublication\s*[Dd]ate=\s*[^\|}\n]+\s*[\|}]").unwrap();
let string = "Pass:
{{Design Pattern
|Title=test
|Publication Date=2021<hier-moet-iets-staan>
}}
Fail:
{{Design Pattern
|Title=test
}}
Pass:
{{Design Pattern
|Title=test
|Publication Date=
2021-32-154
|test=test
}}
Fail:
{{Design Pattern
|Title=test
|Publication Date=
}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}