import Foundation
let pattern = #"\|[pP]ublication\s*[Dd]ate=\s*[^\|}\n]+\s*[\|}]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Pass:
{{Design Pattern
|Title=test
|Publication Date=2021<hier-moet-iets-staan>
}}
Fail:
{{Design Pattern
|Title=test
}}
Pass:
{{Design Pattern
|Title=test
|Publication Date=
2021-32-154
|test=test
}}
Fail:
{{Design Pattern
|Title=test
|Publication Date=
}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)