re = /[A-Za-z0-9]{11}/m
str = 'https://www.youtube.com/watch?v=SEkUienM2oY&t=1265s
https://m.youtube.com/watch?v=SEkUienM2oY&t=1265s
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end