#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?:/\d+)?\D+"
Local $sString = "PENCARROW COMPOSITE ROLL" & @CRLF & _
"178 Wellington Rd, Wainuiomata,Hmmkr ...8 Bull Avenue, Wainuiomata,Housewife ..3/40A Bauchop Rd,Lower Hutt,Scrtry ..26 Castlerea Street, Wainuiomata,Printer 126 Cheviot Rd,Lowry Bay, Hawt" & @CRLF & _
".8 Bull Avenue, Wainuiomata,System Oprtr 144 Cambridge Terrace, Lower Hutt, Butcher 144 Cambridge Tce,Lower Hutt, Housewife ..12 Collingwood St.Lower Hutt,Housewife 12 Collingwood Street, Lower Hutt, Welder ..32 Moohan Street, Wainuiomata,Storeman 8 Burden Avenue, Wainuiomata,Pub Servant .....21 Pollard St,Wainuiomata,Machine Optr 32 Burnside Street, Lower Hutt, Press Wrkr" & @CRLF & _
"8 Burden Avenue, Wainuiomata, Pub Servant" & @CRLF & _
"3 Manurewa Gr.Wainuiomata, Technician" & @CRLF & _
"26 Mimihau Grove, Wainuiomata, Shop Proptr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")