# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+(?:/\d+)?\D+"
test_str = ("PENCARROW COMPOSITE ROLL\n"
"178 Wellington Rd, Wainuiomata,Hmmkr ...8 Bull Avenue, Wainuiomata,Housewife ..3/40A Bauchop Rd,Lower Hutt,Scrtry ..26 Castlerea Street, Wainuiomata,Printer 126 Cheviot Rd,Lowry Bay, Hawt\n"
".8 Bull Avenue, Wainuiomata,System Oprtr 144 Cambridge Terrace, Lower Hutt, Butcher 144 Cambridge Tce,Lower Hutt, Housewife ..12 Collingwood St.Lower Hutt,Housewife 12 Collingwood Street, Lower Hutt, Welder ..32 Moohan Street, Wainuiomata,Storeman 8 Burden Avenue, Wainuiomata,Pub Servant .....21 Pollard St,Wainuiomata,Machine Optr 32 Burnside Street, Lower Hutt, Press Wrkr\n"
"8 Burden Avenue, Wainuiomata, Pub Servant\n"
"3 Manurewa Gr.Wainuiomata, Technician\n"
"26 Mimihau Grove, Wainuiomata, Shop Proptr")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.