re = /\d+(?:\/\d+)?\D+/m
str = 'PENCARROW COMPOSITE ROLL
178 Wellington Rd, Wainuiomata,Hmmkr ...8 Bull Avenue, Wainuiomata,Housewife ..3/40A Bauchop Rd,Lower Hutt,Scrtry ..26 Castlerea Street, Wainuiomata,Printer 126 Cheviot Rd,Lowry Bay, Hawt
.8 Bull Avenue, Wainuiomata,System Oprtr 144 Cambridge Terrace, Lower Hutt, Butcher 144 Cambridge Tce,Lower Hutt, Housewife ..12 Collingwood St.Lower Hutt,Housewife 12 Collingwood Street, Lower Hutt, Welder ..32 Moohan Street, Wainuiomata,Storeman 8 Burden Avenue, Wainuiomata,Pub Servant .....21 Pollard St,Wainuiomata,Machine Optr 32 Burnside Street, Lower Hutt, Press Wrkr
8 Burden Avenue, Wainuiomata, Pub Servant
3 Manurewa Gr.Wainuiomata, Technician
26 Mimihau Grove, Wainuiomata, Shop Proptr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end