import re
regex = re.compile(r"[0-7][0-9A-HJKMNP-TV-Z]{25}", flags=re.MULTILINE)
test_str = ("01G9HHNKWGBHCQX7VG3JKSZ055\n"
"01G9HHNTQY2E8HM5N9AE5SQBXQ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")