package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+?)(?:Local)?$`)
var str = `it.foo.burp.ArticleDAOLocal
it.foo.burp.ArticleDAO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}