package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<Input[ \w=\{\}>\(\)\n;".-:]*ref`)
var str = ` <Input
onClear={() => {
onChange?.("");
}}
ref={ref}
/>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}