re = /<Input[ \w=\{\}>\(\)\n;".-:]*ref/m
str = ' <Input
onClear={() => {
onChange?.("");
}}
ref={ref}
/>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end