$re = '/<Input[ \w=\{\}>\(\)\n;".-:]*ref/m';
$str = ' <Input
onClear={() => {
onChange?.("");
}}
ref={ref}
/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);