package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)-(\w+)`)
var str = `hello-friends`
var substitution = "\1 - \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}