$re = '/(\w+)-(\w+)/m';
$str = 'hello-friends';
$subst = "\1 - \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;