use strict;
my $str = 'hello-friends';
my $regex = qr/(\w+)-(\w+)/mp;
my $subst = '\\1 - \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";