package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(COMPONENTS|PACKAGES)=("?(?<components>\w+)\s?"?)`)
var str = `COMPONENTS="Hello Bye Goodbye"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}