re = /(COMPONENTS|PACKAGES)=("?(?<components>\w+)\s?"?)/m
str = 'COMPONENTS="Hello Bye Goodbye"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end