$re = '/(COMPONENTS|PACKAGES)=("?(?<components>\w+)\s?"?)/m';
$str = 'COMPONENTS="Hello Bye Goodbye"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);