#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]+([- ][a-zA-Z]+)?(, [a-zA-Z]+([- ][a-zA-Z]+)?)?$"
Local $sString = "LastName" & @CRLF & _
"LastName SecondLastName" & @CRLF & _
"LastName-SecondLastName" & @CRLF & _
"LastName, F" & @CRLF & _
"LastName SecondLastName, F" & @CRLF & _
"LastName-SecondLastName, F" & @CRLF & _
"LastName, FirstName" & @CRLF & _
"LastName SecondLastName, FirstName" & @CRLF & _
"LastName-SecondLastName, FirstName" & @CRLF & _
"LastName SecondLastName, FirstName SecondFirstName" & @CRLF & _
"LastName SecondLastName, FirstName-SecondFirstName" & @CRLF & _
"LastName-SecondLastName, FirstName-SecondFirstName" & @CRLF & _
"" & @CRLF & _
"LastName-SecondLastName, FirstName-SecondFirstName!" & @CRLF & _
"LastName-SecondLastName, FirstName#SecondFirstName" & @CRLF & _
"LastName, FirstName, ThirdName" & @CRLF & _
"LastName , FirstName" & @CRLF & _
"" & @CRLF & _
",FirstName" & @CRLF & _
", FirstName" & @CRLF & _
"LastName," & @CRLF & _
"LastName,Any special Character (,?!#@%* etc)" & @CRLF & _
"LastName,FirstName"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")