# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z]+([- ][a-zA-Z]+)?(, [a-zA-Z]+([- ][a-zA-Z]+)?)?$"
test_str = ("LastName\n"
"LastName SecondLastName\n"
"LastName-SecondLastName\n"
"LastName, F\n"
"LastName SecondLastName, F\n"
"LastName-SecondLastName, F\n"
"LastName, FirstName\n"
"LastName SecondLastName, FirstName\n"
"LastName-SecondLastName, FirstName\n"
"LastName SecondLastName, FirstName SecondFirstName\n"
"LastName SecondLastName, FirstName-SecondFirstName\n"
"LastName-SecondLastName, FirstName-SecondFirstName\n\n"
"LastName-SecondLastName, FirstName-SecondFirstName!\n"
"LastName-SecondLastName, FirstName#SecondFirstName\n"
"LastName, FirstName, ThirdName\n"
"LastName , FirstName\n\n"
",FirstName\n"
", FirstName\n"
"LastName,\n"
"LastName,Any special Character (,?!#@%* etc)\n"
"LastName,FirstName")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.