import Foundation
let pattern = #"^[a-zA-Z]+([- ][a-zA-Z]+)?(, [a-zA-Z]+([- ][a-zA-Z]+)?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
LastName
LastName SecondLastName
LastName-SecondLastName
LastName, F
LastName SecondLastName, F
LastName-SecondLastName, F
LastName, FirstName
LastName SecondLastName, FirstName
LastName-SecondLastName, FirstName
LastName SecondLastName, FirstName SecondFirstName
LastName SecondLastName, FirstName-SecondFirstName
LastName-SecondLastName, FirstName-SecondFirstName
LastName-SecondLastName, FirstName-SecondFirstName!
LastName-SecondLastName, FirstName#SecondFirstName
LastName, FirstName, ThirdName
LastName , FirstName
,FirstName
, FirstName
LastName,
LastName,Any special Character (,?!#@%* etc)
LastName,FirstName
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)