const regex = /\/\*[\s\S]*?\*\/|^\s*\/\/.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*[\\s\\S]*?\\*\\\/|^\\s*\\\/\\\/.*$', 'gm')
const str = `alert("text");/*block comment*/alert("text");
alert("text"); // comment
alert("text");// comment no space before
// test
// test
alert("/* */");
alert(" //");
url("data:image/png;base64,/* */");
url("data:image/png;base64,//");
window.location.assign("https://www.go.com")
window.location.assign('https://www.go.com')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}