$re = '/\/\*[\s\S]*?\*\/|^\s*\/\/.*$/m';
$str = 'alert("text");/*block comment*/alert("text");
alert("text"); // comment
alert("text");// comment no space before
// test
// test
alert("/* */");
alert(" //");
url("data:image/png;base64,/* */");
url("data:image/png;base64,//");
window.location.assign("https://www.go.com")
window.location.assign(\'https://www.go.com\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);