import Foundation
let pattern = #"\/\*[\s\S]*?\*\/|^\s*\/\/.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
alert("text");/*block comment*/alert("text");
alert("text"); // comment
alert("text");// comment no space before
// test
// test
alert("/* */");
alert(" //");
url("data:image/png;base64,/* */");
url("data:image/png;base64,//");
window.location.assign("https://www.go.com")
window.location.assign('https://www.go.com')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)