using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^.]*\.[^.]*\.[^.\d]*(\d)";
string input = @"AR0.RRPG.105
AR6.TR0.500
AR0.GGF0.2FEH
AR0.DER.M15
AR0.DER.Maaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa15";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}