$re = '/^[^.]*\.[^.]*\.[^.\d]*(\d)/m';
$str = 'AR0.RRPG.105
AR6.TR0.500
AR0.GGF0.2FEH
AR0.DER.M15
AR0.DER.Maaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);