package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.]*\.[^.]*\.[^.\d]*(\d)`)
var str = `AR0.RRPG.105
AR6.TR0.500
AR0.GGF0.2FEH
AR0.DER.M15
AR0.DER.Maaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}