# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!\s)(.{3,10}\S)(?!\S).*/$1 (...)/mg;t' <<< "This is a long string
this is a test cutting down edges
a b c d e f g h
abcd
abcde
this isatest
is a test
ist a test
ist a te
thiss is a test
a b
a
S
a
ab
abc
abcd
abcde
A bcdefghifkkle
abcd ef g aaa
abcd ef g aa
thisisatesttesttest
abcdefghijkl
"