import Foundation
let pattern = #"^(?!\s)(.{3,10}\S)(?!\S).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is a long string
this is a test cutting down edges
a b c d e f g h
abcd
abcde
this isatest
is a test
ist a test
ist a te
thiss is a test
a b
a
S
a
ab
abc
abcd
abcde
A bcdefghifkkle
abcd ef g aaa
abcd ef g aa
thisisatesttesttest
abcdefghijkl
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 (...)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)