use strict;
my $str = 'This is a long string
this is a test cutting down edges
a b c d e f g h
abcd
abcde
this isatest
is a test
ist a test
ist a te
thiss is a test
a b
a
S
a
ab
abc
abcd
abcde
A bcdefghifkkle
abcd ef g aaa
abcd ef g aa
thisisatesttesttest
abcdefghijkl
';
my $regex = qr/^(?!\s)(.{3,10}\S)(?!\S).*/mp;
my $subst = '$1 (...)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";