using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(\bId="\d+"\b|\b4[78][0-9]{14}\b))(\bhello\b|\b49[0-9]{14}\b)";
string input = @"Id="4912345678912345"
Id="4712345678912345"
4712345678912345
4912345678912345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}