re = /(?!(\bId="\d+"\b|\b4[78][0-9]{14}\b))(\bhello\b|\b49[0-9]{14}\b)/m
str = 'Id="4912345678912345"
Id="4712345678912345"
4712345678912345
4912345678912345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end