use strict;
my $str = 'Id="4912345678912345"
Id="4712345678912345"
4712345678912345
4912345678912345';
my $regex = qr/(?!(\bId="\d+"\b|\b4[78][0-9]{14}\b))(\bhello\b|\b49[0-9]{14}\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}