#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^([1-9]\.[4-9]{1}|[2-9]{0,9}\.[0-9]{1}|[0-9]{2,9}\.[0-9]{1}|[2-9]{0,9})$"
Local $sString = "1.0" & @CRLF & _
"1.1" & @CRLF & _
"1.2" & @CRLF & _
"1.3" & @CRLF & _
"1.4" & @CRLF & _
"1.45" & @CRLF & _
"1.5" & @CRLF & _
"10.3" & @CRLF & _
"15.9" & @CRLF & _
"20.2" & @CRLF & _
"25" & @CRLF & _
"99.1" & @CRLF & _
"100.5" & @CRLF & _
"1000.2" & @CRLF & _
"99999.99" & @CRLF & _
"99999.9" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")