import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\.[4-9]{1}|[2-9]{0,9}\\.[0-9]{1}|[0-9]{2,9}\\.[0-9]{1}|[2-9]{0,9})$";
final String string = "1.0\n"
+ "1.1\n"
+ "1.2\n"
+ "1.3\n"
+ "1.4\n"
+ "1.45\n"
+ "1.5\n"
+ "10.3\n"
+ "15.9\n"
+ "20.2\n"
+ "25\n"
+ "99.1\n"
+ "100.5\n"
+ "1000.2\n"
+ "99999.99\n"
+ "99999.9\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}