package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([1-9]\.[4-9]{1}|[2-9]{0,9}\.[0-9]{1}|[0-9]{2,9}\.[0-9]{1}|[2-9]{0,9})$`)
var str = `1.0
1.1
1.2
1.3
1.4
1.45
1.5
10.3
15.9
20.2
25
99.1
100.5
1000.2
99999.99
99999.9
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}