#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z0-9 ]|[a-zA-Z0-9 ][-#,()\/.])*[a-zA-Z0-9 ]$"
Local $sString = "test" & @CRLF & _
"test" & @CRLF & _
"test2" & @CRLF & _
"2test" & @CRLF & _
"house 1 2 3" & @CRLF & _
"house#" & @CRLF & _
"#house" & @CRLF & _
"house" & @CRLF & _
"big house" & @CRLF & _
"big house" & @CRLF & _
"large #3" & @CRLF & _
"large ##3" & @CRLF & _
"large 1--2" & @CRLF & _
"large 1-2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")