re = /^([a-zA-Z0-9 ]|[a-zA-Z0-9 ][-#,()\/.])*[a-zA-Z0-9 ]$/m
str = 'test
test
test2
2test
house 1 2 3
house#
#house
house
big house
big house
large #3
large ##3
large 1--2
large 1-2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end