import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9 ]|[a-zA-Z0-9 ][-#,()\\/.])*[a-zA-Z0-9 ]$";
final String string = "test\n"
+ "test\n"
+ "test2\n"
+ "2test\n"
+ "house 1 2 3\n"
+ "house#\n"
+ "#house\n"
+ "house\n"
+ "big house\n"
+ "big house\n"
+ "large #3\n"
+ "large ##3\n"
+ "large 1--2\n"
+ "large 1-2\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}