using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h1>[\s\S]*<\/h2>";
string input = @"<!DOCTYPE html>
<html>
<body>
<h1>My First Heading</h1>
<p>My first paragraph.</p>
<h2>My first paragraph.</h2>
</body>
</html>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}