re = /<h1>[\s\S]*<\/h2>/m
str = '<!DOCTYPE html>
<html>
<body>
<h1>My First Heading</h1>
<p>My first paragraph.</p>
<h2>My first paragraph.</h2>
</body>
</html>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end