import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h1>[\\s\\S]*<\\/h2>";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ "<body>\n\n"
+ "<h1>My First Heading</h1>\n\n"
+ "<p>My first paragraph.</p>\n\n\n"
+ "<h2>My first paragraph.</h2>\n\n"
+ "</body>\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}